UK merchant center reports not loading
Incident Report for WePay
Resolved
The merchant center has been resolved and is stable at this time.
Posted Oct 11, 2016 - 12:08 PDT
Monitoring
We have corrected the issue with the UK merchant center and are currently monitoring for stability.
Posted Oct 11, 2016 - 11:09 PDT
Investigating
We are currently experiencing an issue with our UK merchant center when attempting to login. We are investigating the issue now.
Posted Oct 11, 2016 - 09:56 PDT
This incident affected: API, Website, US Processing, Canadian Processing, and Settlements/Withdrawals.