Increased API Endpoint Latency
Incident Report for WePay
Resolved
This incident has been resolved.
Posted Nov 09, 2018 - 07:18 PST
Update
After continued monitoring, this issue is resolved.
Posted Nov 09, 2018 - 07:17 PST
Monitoring
We have introduced a fix to resolve the issue. All remaining `Pending` / `Captured` payments continue to move to a `Captured` / `Released` state and will be resolved shortly. We have confirmed that the pending associated IPN deliveries are in progress. We are continuing to monitor at this time.
Posted Nov 08, 2018 - 18:35 PST
Update
Between 6:01AM PST and 7:40AM PST we were seeing slightly elevated API latency. After continued monitoring we have confirmed no further latency disruption.

At this time we are still experiencing a delay with checkouts moving from a `Pending` / `Captured` state to a `Captured` / `Released` state, depending on your API version. You will still receive an IPN once the state has changed.
Posted Nov 08, 2018 - 12:08 PST
Update
We are continuing work to resolve the issue causing increased API latency and will provide additional updates as work progresses.
Posted Nov 08, 2018 - 09:31 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 08, 2018 - 09:04 PST
Update
We are continuing to work on fixing the issue with api endpoint latency. During this period we have a delay in payments moving to a captured state.
Posted Nov 08, 2018 - 08:35 PST
Update
We are continuing to work on fixing the issue causing increased API endpoint latency and will provide an update in 30 minutes.
Posted Nov 08, 2018 - 08:14 PST
Identified
We've identified the issue causing the increased api endpoint latency and are actively working on a fix.
Posted Nov 08, 2018 - 07:44 PST
Update
We are continuing to investigate this issue.
Posted Nov 08, 2018 - 07:21 PST
Update
We are continuing to investigate this issue.
Posted Nov 08, 2018 - 06:53 PST
Investigating
We are currently investigating an increase in API endpoint latency. During this period, response times for api calls may take longer than expected.
Posted Nov 08, 2018 - 06:53 PST
This incident affected: API, US Processing, Canadian Processing, and UK Processing.