Degraded Production Performance
Incident Report for WePay
Resolved
Please be advised that the previously reported issue where some clients may have experienced degraded production performance has been resolved as of 3:13 PM ET.
Posted Dec 07, 2023 - 12:37 PST
Investigating
Please be advised that we have detected an emerging issue where some clients are experiencing degraded production performance.

Rest assured that we are actively addressing the issue and will publish an update as new information is available.
Posted Dec 07, 2023 - 11:38 PST
This incident affected: API, Website, US Processing, Canadian Processing, Settlements/Withdrawals, and UK Processing.